CompTIA® Network+ Lab Exercise : Connectivity Test With Traceroute

9. Connectivity test with Traceroute

Description: Use the traceroute command to map the IP addresses that a packet travels through to get from one device to another

Connectivity test with Traceroute diagram

Instructions:

1. Configure routers to the specification given below

2. Enable RIP routing across all three routers

3. From Router1, ping the directly connected routers and their interfaces which are Router2 ethernet0 and Router3 serial 0

4. You should be able to ping non-directly connected routers as RIP routing is enabled

5. Next , the traceroute command is entered which helps in determining the path of a packet to its destination.

IP Address Assignment Table

Device Router1 Router2 Router3
Hostname Router1 Router2 Router3
Ethernet 0 192.168.10.2 /24  192.168.10.1 /24  
Serial 0 192.168.20.1   192.168.20.2/24

R1>enable
R1#configure terminal
R1(config)#hostname Router1
Router1(config)# interface ethernet 0
Router1(config-if)#ip address 192.168.10.2 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)# interface serial 0
Router1(config-if)#ip address 192.168.20.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#router rip
Router1(config-router)#network 192.168.10.0
Router1(config-router)#network 192.168.20.0
Router1(config-router)#exit
Router1(config)#exit

R2>enable
R2#configure terminal
R2(config)#hostname Router2
Router2(config)# int ethernet 0
Router2(config-if)#ip address 192.168.10.1 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#router rip
Router2(config-router)#network 192.168.10.0
Router2(config-router)#exit
Router2(config)#exit
Router2#

R3>enable
R3#configure terminal
R3(config)#hostname Router3
Router3(config)# int serial 0
Router3(config-if)#ip address 192.168.20.2 255.255.255.0
Router3(config-if)#no shutdown
Router3(config-if)#exit
Router3(config)#router rip
Router3(config-router)#network 192.168.20.0
Router3(config-router)#exit
Router3(config)#exit
Router3#

Router1#ping 192.168.10.1

Type escape sequence to abort.
Sending 5,100-byte ICMP Echos to  192.168.10.1 ,
Timeout is 2 seconds:
 !!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/6/6 ms

Router1#ping 192.168.20.2

Type escape sequence to abort.
Sending 5,100-byte ICMP Echos to  192.168.20.2 ,
Timeout is 2 seconds:
 !!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/6/6 ms

Router2#ping 192.168.20.2

Type escape sequence to abort.
Sending 5,100-byte ICMP Echos to  192.168.20.2 ,
Timeout is 2 seconds:
 !!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/6/6 ms

Router2#traceroute 192.168.20.2

Type escape sequence to abort.
Tracing route to  192.168.10.1 1000 msec 8 msec 4 msec 
Type escape sequence to abort.
Tracing route to  192.168.10.2 1000 msec 8 msec 4 msec 
Type escape sequence to abort.
Tracing route to  192.168.20.1 1000 msec 8 msec 4 msec 
Type escape sequence to abort.
Tracing route to  192.168.20.2 1000 msec 8 msec 4 msec 

Previous   Contents   Next